Help Function Random Media

Discussion in 'Forums Help & Notices' started by FDelGreco, Jan 27, 2020.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. FDelGreco

    FDelGreco Registered User
    NAWCC Star Fellow Sponsor NAWCC Diamond Member

    Aug 28, 2000
    2,028
    95
    48
    Male
    Retired chemical engineer
    Novelty, OH
    Country Flag:
    Region Flag:
    The left and right arrows on the Random Media appear to be gone!

    Frank
     
  2. FDelGreco

    FDelGreco Registered User
    NAWCC Star Fellow Sponsor NAWCC Diamond Member

    Aug 28, 2000
    2,028
    95
    48
    Male
    Retired chemical engineer
    Novelty, OH
    Country Flag:
    Region Flag:
    No response? Still no arrows!

    Frank
     
  3. KurtinSA

    KurtinSA Registered User
    NAWCC Member

    Nov 24, 2014
    3,595
    136
    63
    Aerospace Engineer (Ret.)
    San Antonio, TX
    Country Flag:
    Region Flag:
    I'm not exactly sure what you're referring to. Do you mean the arrows on either side of the screen when a post has multiple images upload and you click on one of the thumbnails? I don't seem to have any issues there...I still have the arrows. Have you tried logging out and back in? What about clearing cache, cookies, etc.?

    Kurt
     
  4. Tom McIntyre

    Tom McIntyre Technical Admin
    Staff Member NAWCC Star Fellow NAWCC Ruby Member Sponsor

    Aug 24, 2000
    82,693
    1,611
    176
    Male
    retired SW dev
    Boston
    Country Flag:
    Region Flag:
    could not find the arrows in the settings for the feature. They do exist in the template, but I do not know why they are not showing. A lot of the user interface, is written in JavaScript to run in the user's browser. I suspect that some update to the JavaScript library has broken the feature.
     
  5. KurtinSA

    KurtinSA Registered User
    NAWCC Member

    Nov 24, 2014
    3,595
    136
    63
    Aerospace Engineer (Ret.)
    San Antonio, TX
    Country Flag:
    Region Flag:
    I guess then I don't know what Random Media is and what I'm "missing". It might be associated with Albums, but I can't seem to find that either. Can someone direct me to the issue so I can see for myself?

    Thanks...Kurt
     
  6. Tom McIntyre

    Tom McIntyre Technical Admin
    Staff Member NAWCC Star Fellow NAWCC Ruby Member Sponsor

    Aug 24, 2000
    82,693
    1,611
    176
    Male
    retired SW dev
    Boston
    Country Flag:
    Region Flag:
    The main page forum listing by categories has a space at the bottom where Random Media are displayed. It can optionally display either new media or random media. There are 10 images displayed at one time with arrows to scan the ones that are visible. If you double click on one of them, it displays it in the Media Center where user albums and images are stored. Clicking on Media in the top navigation will show the Media Center.
     
  7. FDelGreco

    FDelGreco Registered User
    NAWCC Star Fellow Sponsor NAWCC Diamond Member

    Aug 28, 2000
    2,028
    95
    48
    Male
    Retired chemical engineer
    Novelty, OH
    Country Flag:
    Region Flag:
    Tom:

    Until a couple days ago, I would see 10 random images across the screen. If I put my cursor near the right side of the rightmost image, an arrow would appear. If I click on the arrow the images would shift to the left and two more random images would show on the right. Likewise, there was an arrow on the leftmost image that would move the images back to the right. I still see 10 images now but no arrows appear for shifting. I've rebooted my PC but that didn't help.

    Frank
     
  8. Dick C

    Dick C Registered User

    Oct 14, 2009
    1,637
    55
    48
    Male
    Country Flag:
    My system shows 9 images with a white arrow left and right. When I click on the right one a new image appears.

    However, there are only 10 images shown.

    IF I reduce the font size in my browser (Chrome) to less than 100 % then all 10 images are shown with NO arrows.
     
  9. John Hubby

    John Hubby Senior Administrator Emeritus
    Staff Member NAWCC Star Fellow NAWCC Life Member

    Sep 7, 2000
    12,277
    217
    63
    The Woodlands, TX
    Country Flag:
    Region Flag:
    I'm on a Mac using Firefox and everything still looks the same here, there are 10 photos with only four showing at a time, and the arrows are there to navigate back and forth.
     
  10. KurtinSA

    KurtinSA Registered User
    NAWCC Member

    Nov 24, 2014
    3,595
    136
    63
    Aerospace Engineer (Ret.)
    San Antonio, TX
    Country Flag:
    Region Flag:
    At my current computer monitor zoom, only 9 of the 10 pictures show. But I can click and drag to the left and the tenth picture comes up. On my Android tablet, only a few of the pictures show but I can swipe left or right to see the rest.

    Kurt
     
  11. PatH

    PatH Registered User
    NAWCC Fellow NAWCC Member

    Dec 5, 2014
    1,658
    1,140
    113
    Female
    Texas
    Country Flag:
    Region Flag:
    Android phone - 2 images appear on the screen and I can scroll/flip with my finger through a total of 10 images. No arrows.
     
  12. Dave Coatsworth

    Dave Coatsworth Senior Administrator
    NAWCC Business Sponsor

    Feb 11, 2005
    7,010
    1,832
    113
    Male
    Watch Parts Dealer
    Camarillo, CA
    Country Flag:
    Region Flag:
    Seems to me that it is behaving properly. There are only 10 media images. If you have sized your screen so that all 10 are shown, it makes sense that there are no arrows because there is nothing else to scroll to.

    My question is... Why are there only 10 images? Certainly we have more interesting stuff to show than that!
     
  13. KurtinSA

    KurtinSA Registered User
    NAWCC Member

    Nov 24, 2014
    3,595
    136
    63
    Aerospace Engineer (Ret.)
    San Antonio, TX
    Country Flag:
    Region Flag:
    Probably a setting in the forum background to allow 10 at a time. You can click on the word Random Media in the banner and see many, many images. Interestingly though, the current images at the bottom of the main board page don't seem to be included in the most recent list of images.

    Kurt
     
  14. Tom McIntyre

    Tom McIntyre Technical Admin
    Staff Member NAWCC Star Fellow NAWCC Ruby Member Sponsor

    Aug 24, 2000
    82,693
    1,611
    176
    Male
    retired SW dev
    Boston
    Country Flag:
    Region Flag:
    The feature may optionally list random media or most recent media. It is currently set for random. It changes from time to time while you are on-line. The feature may change some when we deploy the new Message Board in a month or two.

    As I mentioned before, the code that controls the display of the arrows is written in JavaScript which behaves differently on different browsers and browser settings. I am not smart enough to fix it. :(
     

Share This Page