• We are aware of the performance issues with the forum. These are due to problems with Comcast's lines in the Columbia, PA area. We are working on the immediate issue with Comcast and are also working on a long term plan that will eliminate our reliance on Comcast. Thank you for your patience.

How long before posts are indexed for searching?

Spaceman Spiff

Registered User
Jun 19, 2006
1,437
14
38
St. Petersburg, Florida
www.myspace.com
Country
Region
Hello.

I'm wondering how long it takes before posts are indexed in order to be found while using the search feature.

I received a PM from a new member who had read some of my posts and guessed that I might be able to identify his Ridgeway clock. He told me in the PM that he had made a post in the fourm and had included some photos there. Since he didn't say which section of the forum, I simply ran a search on the word "Ridgeway" but couldn't find his post. I had to write back to him to ask where his post was. He wrote back and told me it was in the Clocks General forum and told me the title. I found the post, and it clearly has the word "Ridgeway" in it:

https://mb.nawcc.org/showthread.php?87110-New-member-with-a-question

He posted it on 4/25 but it still won't come up by searching with the word "Ridgeway."

How long does it take before posts can be found using Search?

Thanks,
 

John Hubby

Senior Administrator Emeritus
Staff member
NAWCC Star Fellow
NAWCC Life Member
Sep 7, 2000
12,294
248
63
The Woodlands, TX
Country
Region
John, the search engine is supposed to update every 15 minutes or thereabouts. However, when I made the same search you did it pulled up 148 threads but the last time a "Ridgeway" post or thread is recorded was given as April 21. We known there are quite a few since then. I tried some other searches for known posts with mixed results, some came back with the latest posts and some not. Something is rotten in Denmark!

Tom and Anthony, need some help here!
 

Tom McIntyre

Technical Admin
Staff member
NAWCC Star Fellow
NAWCC Ruby Member
Sponsor
Aug 24, 2000
84,393
2,102
113
85
Boston
awco.org
Country
Region
There is something very subtle that is wrong with the search facility. Anthony has been working on it. The index process is running and reports that the indexing is OK, but the indexes are not getting updated.

In order to get the speed problem fixed, the server has been rearranged internally and that seems to have exposed some problems in where the software is looking for resources.
 
A

AnthonyG

Due to a system cron issue, it was not indexing, i thought i had resolved it last week, that was not the case, testing it today, the issue is now resolved.

The standard rotation of the files is every 3 minutes.

You post --> post is stored in the database for the forums --> cron runs every 3 minutes --> post is extracted and entered in the file.

Depending on your post time, it may show up in seconds, depends on how your post coincides w/ the cron running.
 

John Hubby

Senior Administrator Emeritus
Staff member
NAWCC Star Fellow
NAWCC Life Member
Sep 7, 2000
12,294
248
63
The Woodlands, TX
Country
Region
Anthony, thanks for your help! Good to see the search working again.
 

Forum statistics

Threads
169,926
Messages
1,483,106
Members
49,243
Latest member
Ralphallais
Encyclopedia Pages
1,060
Total wiki contributions
2,965
Last update
-